---
title: "Starting Netsense sensor"
canonical: "https://thoughtdata.refined.site/space/TUD/55643206/Starting%20Netsense%20sensor"
format: markdown
---
## Activating Netsense

Once Netsense is installed and configured, you can 

- Start the Netsense processes
- Check the status of the working processes and gather statistics
- Verify that connectivity between your Netsense and Enterprise360 is working.

Perform the following steps.

Go to  **"cd /usr/local/thoughtdata/netsense/bin"** directory of the Netsense installation. 

Use the ls command to list files in the directory.

![image](media://17b426f6-e0ef-412c-8c82-c31b8977d452)

Go to bin directory and list contents

Run **./start" t**o start your Netsense sensor. 

Run **"./ps"** to verify if your Netsense process has started.

![image](media://82f12ed2-cb19-4b6b-b95b-295e5ee02122)

Check if tdnetsense process is running on the interfaces you configured in node.cfg earlier.

Run ".**/td_cli 8001" **to get Netsense processes statistics after about **3 minutes**. of start

![image](media://bfa49da7-fcb2-4993-952a-7b7718c7430a)

Check for the string **"Reporting Started". **If you see this, your Netsense is successfully communicating to your Enterprise360. If you see **"Reporting Stopped"** this means, your Netsense is unable to communicate to your Enterprise360. 

If you see status **"Reporting Started" **be assured that your Netsense sensor is working fine and you can  proceed to verifying the data sent by Netsense in Enterprise360.

**Debugging problems with Netsense Packet Sensor**

If your Netsense packet sensor process does not start or it is unable to communicate to your Enterprise360, you can debug for the cause using NetSense log files as illustrated below:

Go to** "cd /usr/local/thoughtdata/netsense/bin"** directory.

Run **"cat tdnetsensedebug.log"** to view the log file and check for error messages.

A few common reasons that the NetSense process does not start or is unable to communicate with Enterprise360 are:

1. The interface you configured in node.cfg is either not up or you configured it wrongly.
2. There is no network connectivity between your Netsense and Enterprise360.
3. There is a firewall between your Netsense and Enterprise360 blocking internal communication over port . Port 9093 needs to be opened if there is a firewall between your Netsense and enterprise360.
4. There is a NAT(Network Address Translation going on in the communication path between Netsense and Enterprise360.
5. Netsense was not properly installed and few of the dependent libraries installation failed either due no internet access or due to no connectivity to Linux OS repositories.
6. There is a version compatibility issue between your Netsense and Enterprise360.

Contact info@thoughtdata.com for ThoughtData's customer support team to have a look at your issue and help you with a proper resolution.