---
title: "Discovering servers"
canonical: "https://thoughtdata.refined.site/space/TUD/57673008/Discovering%20servers"
format: markdown
---
You can use Enterprise360 to auto-discover servers for monitoring infrastructure performance.

On Linux based servers SSH method is used for auto discovery 

- SSH has to be enabled
- port 22 has to be open on server as well as firewalls.

On Windows based servers WMI method is used for auto discovery

- WMI has to be enabled
- port 135 has to be open on server as well as firewalls.

Related Topic

1. [WMI Permissions](WMI_Permissions.htm)

#### Authentication

A common username and password can be configured for the discovery  process for Linux and Windows networks. This set of credentials is used to authenticate each server identified by the discovery process. 

All credentials configured in Enterprise360 are encrypted and stored securely within Enterprise360.  No credential  is used as open text during configuration or during communication, provisioning or monitoring in Enteprise360.

Once configured Enterprise360 initiates the discovery process, validates authentication, discovers the server and auto-provisions the servers for continuous monitoring.

The discovery process automatically assigns the servers to the sensor during the discovery configuration.  It is important to load balance the servers across multiple sensors for optimal performance and scalability.

- All Linux servers/machines should be assigned to InfraSense-Linux,
- All Windows servers/machines should be assigned to InfraSense-Windows

Servers that fail to get authenticated are flagged as "discovered" but not "provisioned". Such servers will not be available for monitoring unless the authentication issue is resolved. 

#### Resolving Authentication Issues

If authentication fails because of common username/password, users can perform one of the following steps:

- fix the credential issues in each server in the network

OR

- provision the server manually using its own specific username/password

##### Authentication in case of SNMP Deployment

Users have the option to deploy the SNMP method for infrastructure monitoring on Linux and Windows based servers.   

    If this method is deployed 

- delete the host using the "Entity Configuration" option and
- add the host in the SNMP configuration.

Refer to the SNMP sense configuration section for details.

**Note**: Some of the infrastructure metrics collected from SSH and WMI methods are not available in SNMP due to limitations of SNMP methods and MIBs enabled on the server.

#### Re-discovery

After fixing the authentication requirements for servers (SSH/WMI) that failed during initial provisioning, the discovery process attempts to re-discover the servers in the next scheduled discovery cycle.  As part of setting the discovery configuration, you can opt to run the re-discovery process:

- daily
- weekly or
- monthly

The rediscovery process ensures that:

- new servers that did not exist earlier in the network are auto-provisioned,
- old servers that had failed authentication are re-provisioned,
- old servers that were provisioned are  retained as is,
- old servers that no longer exist in that network are decommissioned

 **Note**: Set the re-discovery  frequency - daily, weekly or monthly to suit your needs.